Avisos
Vaciar todo

[Resuelto] Problema con los formularios de la web  

Página 1 / 2
 
Ana
 Ana
Estimable Member

Hola Buen día,

Espero que esteis bien.

Tengo un problema con los formularios de la web, si relleno los campos de forma normal y le doy a enviar, se queda como pensando-procesando y no envia

el formulario, pero es que tampoco ni aparece ningun mensaje, ni de enviado ni de que existe algun erro, nada de nada,que queda ahí dando vueltas   🙄 

 

Que puede suceder?

Podeis echarme una mano por favor?

 

Gracias por anticipado!

 

Ana

 

 

Contenido solo visible a usuarios registrados

Respondido : 09/03/2022 12:26 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana, 

Veo que actualmente se está generando un error en el function de tu tema

[09-Mar-2022 12:29:03 UTC] PHP Fatal error: Uncaught TypeError: Argument 1 passed to cs_phpmailer_init() must be an instance of PHPMailer, instance of PHPMailer\PHPMailer\PHPMailer given, called in /home/taller43/public_html/wp-includes/class-wp-hook.php on line 307 and defined in /home/taller43/public_html/wp-content/themes/carservice/functions.php:250

¿Has realizado algún cambio reciente en tu sitio web como actualizar la versión de tu WordPress?, de igual forma veo que tienes un recaptcha que no está funcionando 

Screenshot   2022 03 09T084402.382

Verifiquemos varias cosas, lo primero es comprobar si algún plugin puede estar afectando el sitio web o generando algún tipo de error, para revisarlo desactiva todos los plugins y deja solo los requeridos por tu tema y el formulario, luego de ello prueba realiza un envió desde tu formulario de contacto, si no se muestra ningún error y se envía de forma correcta ve activando uno por uno mientras pruebas cuál puede causar el conflicto. 

Si con ello no funciona, verifica si al cambiar tu tema de forma temporal  y prueba realizar un envió y comprueba si con ello se envían de forma correcta. 

Verifica esto y nos comentas como ha ido todo

Un Saludo

 

Respondido : 09/03/2022 12:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ana
 Ana
Estimable Member

Hola Karen,

Espero que estés bien. 😊 

Bueno... ya hice todo lo que me has indicado.

- He vuelto a una version anterior del WP, concretamente a la 5.7, a ver si así hacia efecto, y nada, hace lo mismo.

- He desconectado todos los plugins que no son esenciales, y nada, tampoco se arregla sigue quedandose como procesando.

- Al final también cambié el theme por otro de los que van en al wordpress y al hacer eso la web entera se rompió. No se cargaba bien, se veian como códigos y shortcodes.

Un desastre.

Así que lo que he tenido que hacer es volver a cargar una copia de seguridad, porque cuando quise activar su theme tampoco iba bien, igualmente se veian los shiortcodes y codigo en el frontend . Así que estoy como al principio, con todo sin actualizar.. y sin foncionar los formularios  😞

Lo que me doy cuenta es de que antes de actualizar ya no iban los formularios, a saber desde cuando.

 

Que podemos mirar ahora?

 

Sobre lo del reCaptcha, pues el que tengo implementado es el V3 y no debería salir ese código, sinceramente he revisado la pagina contactar y la configuración del correo

y no se donde puedo quitar ese shortcode de recaptcha. 🙄

Hoy no es mi dia. 😑

 

 

Quedo a la espera, gracias!

Ana

 

Respondido : 09/03/2022 4:10 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Veo que el formulario forma parte del código del tema, es decir al momento de agregarlo posiblemente sea por un módulo que te provee el tema, en este caso verífica el cambiarlo por uno de contact form 7 que veo que también lo tienes instalado, para ello ingresas el módulo directamente de contact form 7 que se debe mostrar entre la lista de módulos disponibles en tu constructor del sitio.

Una vez realizado esto, si el complemento de contact form 7 sigue sin enviar el mensaje prueba subiendo tu versión php a 8.0 solo por verificar:

https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Un saludo 🖐️ 

Respondido : 09/03/2022 4:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ana
 Ana
Estimable Member

Hola Argenis,

 

Gracias por tu ayuda. 😊 

Pues... de hecho ya tengo el plugin Contact Form7 instalalado en la web, concretamente en "Trabaja con Nosotros"

https://talleresirm.com/trabaja-con-nosotros/

Pero le pasa exactamente lo mismo, que al enviarlo se queda como pensando/procesando y de ahí no sale y no envia nada.

 

Sobre PHP tengo el 7.3, y lo he actualizado a PHP 8.0 pero la web no se ve, se rompe, da error, así que he probado con

PHP 7.4 y ese lo soporta, no se rompe la web. Pero es igual porque al probar el formulario de nuevo, sigue con lo mismo.  😓  

 

Que podemos probar ahora?   Que locura 😒 

 

Quedo a la espear. Muchas gracias por ayudarme.

Ana

Respondido : 09/03/2022 5:01 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Verifica el tener en tu sitio una versión antigua de contact form 7 solo por hacer una prueba, para ello puedes verificar con este complemento:

https://es.wordpress.org/plugins/wp-rollback/

Es bastante intuitivo, simplemente vas a tu lista de plugins y al seleccionar contact form tendrás una opción nueva que indica rollback.

Prueba también configurar que el envío de tus correos no lo haga el servidor a través de pop, sino con smtp para ello puedes seguir nuestra guía:

https://www.webempresa.com/blog/smtp-en-wordpress.html

Verifica esto y nos vas comentando cualquier duda que surja.

Un saludo 🖐️ 

Respondido : 09/03/2022 5:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Estimable Member

Hola Argenis,

Gracias por tu ayuda, de verdad.

Ya he instalado el RollBack y he instalado el Contact Form7 5.4 que es de Feb. 2021, pero hice pruebas de nuevo y sigue con el mismo problema.

He hecho una captura de pantalla (ver foto adjunta) de donde están los datos de configuración de correo y creo que en teoría lo que usa es SMTP.

 

Estaba pensando... quizás es que ese mñodulo de configuración e correo no funciona como es debido?  🤔 

Mis conocimientos son limitados y no se como, pero quizás tu sabes si hay alguna forma de saberlo?

Y si no va que puedo hacer? instalar un plugin que lo haga?

 

Quedo a la espra.

 

Muchas gracias Argenis.

Ana 

 

 

Respondido : 09/03/2022 5:23 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

No se envió la captura, por otra parte mencionas que trabajas con smtp pero no veo activo ningún complemento para hacer esto, por lo tanto, porque nos comentas que estás utilizando este método?

https://soporteforo.webempresa.eu/guia/subir-imagenes-a-consultas-en-foro/

Un saludo 🖐️ 

Esta publicación ha sido modificada el hace 3 meses por Argenis
Respondido : 09/03/2022 5:29 pm

Cursos Gratuitos WordPress

Ana
 Ana
Estimable Member

Perdón Argenis,

Se me olvido adjuntar la imagen, ahora si la adunto. Perdoname.

Ahora mismo me has pillado intalando WP Mail SMTP

screencapture talleresirm

Ana

Respondido : 09/03/2022 5:31 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Entiendo que entonces el tema trabaja con smtp, hagamos una prueba, cambiemos el tema aunque se desconfigure todo e ingresa a la url que tiene el formulario de contact form 7 y verifica si este formulario se envía sin el tema activo, es probable que el smtp configurado en tu tema este ocasionando el problema.

Un saludo 🖐️ 

Respondido : 09/03/2022 5:41 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ana
 Ana
Estimable Member

Hola Argenis,

He instalado y configurado el plugin WP Mail SMTP by WPForms   y cuando lo acabo de configurar y se hace el envio de email de prueba tambien me da error,

que desespero!

Te adjunto imagen con el error:

 

error 500

He repsado la configuración y parece que esta correcto, no se que es ese error 500 🙄 

 

Gracias,

Ana

 

 

Respondido : 09/03/2022 5:45 pm
Ana
 Ana
Estimable Member

Argenis,

 

Ahora lo que hice... probando cosas... es borrar los datos de la configuración de correo deltheme y dejar solo la del plugin que acabo de instalar.

Y ahora si me da un error en el formulario de contact form7, te adjunto imagen (los otros no irán, ya que van con esa configuracion del theme)

error form

<Gracis por tu paciencia

 

Ana

Respondido : 09/03/2022 5:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana, 

En este caso realiza la prueba que te ha comentado Argenis previamente, es posible que el error se esté generando con el tema. Para realizar la prueba realízalo en un clon de tu sitio web, de esta forma no se afectará la visualización actual de tu sitio web de activo

Te comparto el siguiente artículo donde se menciona como hacer un clon de forma rápido -> https://www.webempresa.com/blog/clonar-wordpress-en-3-clics-sin-perder-tiempo.html

De igual forma envíanos que mensajes te muestra el error log de tu sitio web, para ello ingresa a tu cPAnel -> Administrador de archivos -> public_html y en la carpeta raíz ubica el archivo error_log, envíanos los mensajes que se muestran en este error 

Un Saludo 

Esta publicación ha sido modificada el hace 3 meses 2 veces por Karen Rios
Respondido : 09/03/2022 5:52 pm
Ana
 Ana
Estimable Member

Hola Karen, 😊 

Ok, ahora he de irme, pero mañana será lo primero que haga.

A ver si podemos solucionar este problema.

Muchas gracias por vuesta ayuda!!

Ana

 

Respondido : 09/03/2022 5:55 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana, 

De acuerdo, quedamos atentos como ha ido todo con las pruebas

Un Saludo 

Respondido : 09/03/2022 6:12 pm
Página 1 / 2