Avisos
Vaciar todo

Problemas en la traducción automática del menú con Polylang.  

 
PATRICIA
 PATRICIA
Nuevo usuario

Hola,

Mi situación es que tengo el tema Bridge, y quiero traducir la web. Para eso instalé Polylang. Dupliqué las páginas y traduje todos los textos. E hice lo propio con los menús.

El problema es que:

-Cuando clico en la banderita de "inglés", toda la web cambia a ese idioma, menos el menú, que se queda en español. Y sí la página está en inglés y le doy a la banderita de "español", ocurre lo contrario, cambia todo menos el menú. Es decir, que el clicar en las banderitas no hace que cambien los menús de idioma. Y, por supuesto, si clicamos alguna opción del menú, nos redirige a la parte de la web que está en el mismo idioma que el menú.

-Tengo instalado el plugin "Bloom". Con él tengo dos formularios de suscripciones en la página principal. Pero cuando cambio de idioma, desaparecen. He desactivado el Bloom para probar pero el problema con los menús persiste.

Os dejo los enlaces a los dos idiomas de la web. Si necesitáis algún detalle más, por favor, decídmelo.

https://centrolamacarena.com/es/

https://centrolamacarena.com/en/

 

Muchas gracias.

Contenido solo visible a usuarios registrados

Citar
Respondido : 21/04/2021 5:11 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes establecidos los menús para cada idioma?

Tendrías que tenerlo tal como se comenta en la documentación:
https://polylang.pro/doc/create-menus/

Envíanos algunas capturas de pantalla.

Prueba ir desactivando igualmente plugins, en caso alguno de ellos te este causando el problema.

Saludos.

ResponderCitar
Respondido : 21/04/2021 5:17 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

PATRICIA
 PATRICIA
Nuevo usuario

@jmarreros

 

Hola,

Sí, creé dos menús, uno para cada idioma. He seguido los pasos del enlace, pero tengo otra versión. Así que las opciones aparecen de manera diferente. Adjunto capturas (si necesitas más, coméntamelo).

También he probado a desactivar los otros plugins uno por uno y el problema no desaparece.

Captura menu eng
Captura menu esp
Captura ajustes

 

Gracias.

 

ResponderCitar
Respondido : 21/04/2021 6:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tu configuración parece correcta, al probar tu sitio No noto que se recargue la página al usar los enlaces de las banderas, es como si estuviera programado para mostrar contenido en una one page (desplazándo sólo al inicio).

Tienes que revisar como cambiar esto en tu theme ya que algunos enlaces si que deberían recargar el navegador y no comportarse como one page y eso es lo que al parecer esta afectando a los enlaces de cambio de idioma.

Saludos.

 

ResponderCitar
Respondido : 21/04/2021 6:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress