Avisos
Vaciar todo

The response is not a valid JSON response - Plugin Site Kit Google  

 
MONICA
 MONICA
Nuevo usuario

Buenas tardes! 

Les escribo a ver si me pueden ayudar con un error que me ha aparecido en mi wordpress y me pueden dar alguna indicación para solucionarlo. Hace unas semanas instalé el plugin Site Kit by Google para conectar wordpress con google analytics, search console, etc...

Después de conectar el plugin con mi cuenta de google asociada y dejarlo sincronizar para recuperar las vistas de visitas, etc, el plugin me muestra visualmente estos dos errores: 

Error de datos en Search Console

The response is not a valid JSON response.

Error de datos en Analytics

The response is not a valid JSON response.

 

Este error no me había aparecido antes en ningún apartado de la web. Antes de abrir este ticket he estado buscando en este mismo foro y encontré este hilo, pero no he conseguido solucionarlo. He revisado bien que no haya contenido mixto en mi web, y estoy casi segura que no lo tengo. Para comprobarlo he utilizado la web: https://www.whynopadlock.com/ y me ha devuelto como que no hay contenido mixto. También he instalado el plugin Really Simple SSL para hacer las correcciones oportunas en el caso que tuviera algo mal, y tampoco me ha resuelto el problema.

He instalado y desinstalado el plugin un par de veces (borrando todos los datos y carpetas) para ver si era un error puntual. Pero nada, se repite continuamente.

Buscando información por mas foros en internet, he encontrado esto: https://passionwp.com/response-is-not-a-valid-json-response-error/

Veo que hace referencia a varias cosas, al editor, al contenido mixto, enlaces permamentes... Todavía soy una usuaria novata y tengo poca experiencia en programación y en configuraciones avanzadas por lo que no quiero empezar a hacer modificaciones sin saber muy bien para qué. Además tampoco me cuadra demasiado con mi problema

He intentado adjuntar una captura del error para que sea más fácil verlo, pero no he visto que se pueda agregar adjuntos al ticket.

Me vendría bien alguna recomendación técnica para intentar solventar el problema 🙂

¡Muchas gracias de antemano!

Mi web: https://www.rubiaporqueeltintemehizoasi.com

Contenido solo visible a usuarios registrados

Citar
Respondido : 12/08/2021 5:14 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Monica, 

En este caso verifica si algún plugin está ocasionando un conflicto con el plugin de Site Kit google, prueba dejar solo activos los requeridos por tu tema y verifica si no muestran ningún error, si es así, ve activando uno por uno hasta determinar cuál causa este conflicto.

Verifica esto y nos comentas como ha ido todo

Un Saludo 

 

ResponderCitar
Respondido : 12/08/2021 5:39 pm

Cursos Gratuitos WordPress

MONICA
 MONICA
Nuevo usuario

Hola Karen!

Muchas gracias por tu respuesta. He seguido los pasos que me has indicado, pero no ha funcionado.  El problema seguía siendo el mismo:

  • Se producía el error Json al intentar recuperar los datos desde la search console y google analitics
  • Google analytics no registraba las visitas que se hacen a la web (ni si quiera mandandole una petición directa desde el propio portal de google dentro de mi cuenta).

Después de darle muchas vueltas, he decidido hacer una prueba más. Me he bajado una copia de mi web desde el servidor de Webempresa a mi propio pc y he montado xampp en local, he exportado la base de datos, etc..

¡Voila! Ha empezado a funcionar. Google Analitics ha empezado a registrar actividad (seguía teniendolo vinculado) y Google Site Kit ha recibido los datos correctamente (todo esto en la instalación en local que he hecho). El error Json ha desaparecido. En cambio, desde la web en el hosting sigue dando el error.

A partir de aquí ya me pierdo por mi falta de experiencia, ¿es posible que tenga activado en mi hosting algún protocolo de seguridad o firewall que esté produciendo un corte en el protocolo de comunicación? La verdad que no tengo ni idea por donde empezar a mirar. ¿Es posible que el certificado SSL tenga algo que ver? Me da la sensación que el fallo lo está dando desde que cambié de Http a Https (aunque no estoy segura del todo).

Gracias de nuevo por tu atención,

Quedo a la espera de vuestros comentarios.

ResponderCitar
Respondido : 12/08/2021 8:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según lo que comentas, entiendo que en local lo que no aparece es el error.

Lo primero sería, es necesario para tu sitio que instales el plugin Site Kit by Google ?, te lo comento porque este tipo de plugins usualmente volverán pesados tu sitio y en realidad no vale mucho la pena si puedes ver estadísticas directamente desde las páginas oficiales de Google Analytics.

Si aún lo crees necesario, efectivamente, es posible que por seguridad u optimización se esten bloqueando algunas peticiones, consulta a través de tickets de soporte para ver si detecan algo comena que recuperaste tu sitio en local y allí si te funciona con el plugin.

Saludos.

ResponderCitar
Respondido : 12/08/2021 8:44 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

MONICA
 MONICA
Nuevo usuario

Muchas gracias por tu respuesta Jhon.

Intentaré resolverlo abriendo una consulta con el soporte de mi hosting.

ResponderCitar
Respondido : 12/08/2021 9:14 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Monica, 

De acuerdo, quedamos atentos como ha ido todo

Un Saludo 

ResponderCitar
Respondido : 12/08/2021 9:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress