Idioma front redirige mal  

 
Carles
 Carles
Usuario eminente

Tengo una consulta por si me podriais ayudar, al cambiar el idioma en el fron de español a ingles por ejemplo me redirecciona a:
https://thegolfsquare.com/en/the-golf-square-more-than-a-golf-shop
y no me deja quitarlo.
luego al cambiar a español hace exactamente lo mismo:
https://thegolfsquare.com/es/the-golf-square-more-than-a-golf-shop

yo necesitaba que redireccionase a:  https://thegolfsquare.com/en/  y  https://thegolfsquare.com/es/
podria indicarme como hacerlo, no logro encontrar la solucion en ningun foro

Citar
Respondido : 12/04/2020 11:39 am
Carles
 Carles
Usuario eminente
Respondido por: @llorenc-solegmail-com

Tengo una consulta por si me podriais ayudar, al cambiar el idioma en el fron de español a ingles por ejemplo me redirecciona a:
https://thegolfsquare.com/en/the-golf-square-more-than-a-golf-shop
y no me deja quitarlo.
luego al cambiar a español hace exactamente lo mismo:
https://thegolfsquare.com/es/the-golf-square-more-than-a-golf-shop

yo necesitaba que redireccionase a:  https://thegolfsquare.com/en/  y  https://thegolfsquare.com/es/
podria indicarme como hacerlo, no logro encontrar la solucion en ningun foro

Ademas de ese error al ir a pagar me sale error 500 en el servidor antes de pagar en el proceso de compra

ResponderCitar
Respondido : 12/04/2020 12:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy raro, tal vez es poque lo tengas en cache, desde: Parámetros Avanzados > Rendimiento, prueba eliminar la cache o desactívala temporalmente.

Qué módulo estas usando para la selección de idiomas, busca en su configuración.

PD. Tu segunda consulta mejor plantéala en un nuevo hilo de discusión, de esta forma no mezclamos temas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/04/2020 2:17 pm
Carles
 Carles
Usuario eminente

@jmarreros

ya he probado a borrar la cache y sigue saliendo... nose cual puede ser el error

ResponderCitar
Respondido : 12/04/2020 2:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué módulo usas para selección de idioma, veo que la url ya se crea como parte del módulo.

Envíanos una captura de pantalla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/04/2020 3:26 pm
Carles
 Carles
Usuario eminente
Respondido por: @jmarreros

Hola

Qué módulo usas para selección de idioma, veo que la url ya se crea como parte del módulo.

Envíanos una captura de pantalla.

Saludos.

dgvsfzgbfr

ResponderCitar
Respondido : 12/04/2020 3:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba instalar un nuevo idioma y verifica si te sucede lo mismo. Desde Internacional > Localización, selecciona el país y luego importar.

Envíanos una captura de pantalla de , Internacional > Localización > Idiomas

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/04/2020 5:08 pm
Carles
 Carles
Usuario eminente
Respondido por: @jmarreros

Hola

Prueba instalar un nuevo idioma y verifica si te sucede lo mismo. Desde Internacional > Localización, selecciona el país y luego importar.

Envíanos una captura de pantalla de , Internacional > Localización > Idiomas

Saludos.

gasw4artg43etg4r

al añadir otro idioma hace lo mismo.

ResponderCitar
Respondido : 12/04/2020 5:33 pm

Cursos Gratuitos WordPress

Carles
 Carles
Usuario eminente

ya esta solucionado lo de la redireccion (en el index estaban mal puestas las redirecciones) pero al cambiar de español a ingles por ejemplo luego no puedes cambiar a español de nuevo.

ResponderCitar
Respondido : 12/04/2020 6:09 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que sucede lo mismo con todos los desplegables, también pasa con la moneda.

¿Qué cambios has ralizado?, ¿antes funcionaba?,  de manera general parece ser algún problema de conflicto con algún otro módulo o con el theme.

Si has instalado/modificado algo recientemente, revierte los cambios y verifica.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/04/2020 8:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carles
 Carles
Usuario eminente

@jmarreros

hicimos las pruebas antes de pasarlo todo en otro hosting y funcionaba todo perfectamente, al cambiarlo a este es cuando ha empezado a dar esos fallos. no hemos hecho ningun cambio

ResponderCitar
Respondido : 13/04/2020 9:33 am
Carles
 Carles
Usuario eminente

Solucionado, era una incompatibilidad con el modulo presta speed.

muchas gracias por su ayuda!!!

ResponderCitar
Respondido : 13/04/2020 10:31 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Que bueno que lo solucionaste.

Gracias por el aporte.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/04/2020 6:15 pm

Por favor Iniciar Sesión o Registro