Prestashop no me muestra los precios  

Página 1 / 3
 
Enrique
 Enrique
Famed Member

Buenas tardes,

He actualizado Prestashop a la versión 1.6.1.17. Me encuentro con el siguiente problema:

1. En la parte púlblica el precio del producto es 0. Adjunto captura:

Si le doy a "Añadir a carrito" aparece igual a 0, pero si en el carrito le sumo una unidad más al producto aparece el precio correcto. Adjunto captura:

Es como si lo único que no cargase fuera el primer precio con una unidad, después al suma dos unidades el precio si está correcto.

Por otra parte, en el back office los productos aparecen así:

Sin embargo, si entro dentro del producto, si le doy a modificar el precio está ahí

lo que no calcula es el precio con impuesto.

Tengo copia de seguridad y todo eso pero ya he actualizado de varias formas y de varias maneras y siempre me pasa lo mismo. Creo que es un bug de prestashop que podemos solucionar o alguna falla no?

Gracias.

Espero noticias.

Un saludo, Enrique P.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 21/11/2017 10:44 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

Lo que veo es que te falta la celda de " Precio de venta con IVA " que es de donde toma los datos:

.- Comprueba que no tengas actualizacines de extensiones pendientes, si es así, previa copia de seguridad, lo actualizas.

Revisa la versión de PHP que tienes instalada en tu cuenta de cpanel y la modificas por la 7x, esto lo puedes realizar fácilmente desde tu cuenta de cpanel->Software -> Configurar PHP

Te dejo información -> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/11/2017 11:23 am

Cursos Gratuitos WordPress

Enrique
 Enrique
Famed Member

Buenas tardes Pepe,

He realizado la prueba y me sigue apareciendo igual.

He comprobado si hay módulos pendientes de actualizar y está todo actualizado.

Gracias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 21/11/2017 1:35 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Envíanos alguna captura de pantalla del detalle de algún producto en donde podamos ver los precios que le has asignado. Asegúrate que todos los campos tengan un valor diferente de cero.

Si agregas un nuevo producto manualmente te sucede lo mismo?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/11/2017 4:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes,

Adjunto captura. No puedo entrar producto a producto en miles de productos para poner algo donde aparece el cero que antes no aparecía. Más arriba tienes una captura de pantalla.

Te adjuno otra.

Por otra parte, he creado un producto de prueba pero aparece igual que la fonto que adjunto.

http://eurotex.es/clifrihos/formadoras-de-hamburguesa-/2993-prueba.html

Gracias.

Espero noticias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 21/11/2017 5:00 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

Para pobrar crea un nuevo producto y en este asegúrate de tener un valor al menos también en precio unitario y verifica.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/11/2017 8:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Famed Member

Buenas tardes,

Le he puesto 50 pero igual que si no le pusiera nada, no me calcula por ejemplo el precio sin IVA.

Creo que le ha pasado a más personas, por internet hay algunas cosas pero no soy el único.

Gracias.

Espero noticias.

Un saludo,

ResponderCitar
Respondido : 22/11/2017 6:25 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Algo que podrías probar es descartar si es un problema con tu theme, en un clon de tu sitio podrías realizar la prueba de cambiar de theme, usa el theme que viene por defecto.

Revisa:
https://www.webempresa.com/blog/clonar-una-instalacion-de-prestashop-a-otra-carpeta-del-hosting.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/11/2017 8:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes,

He realizado el cambio de plantilla y sigue igual, de eso no puedo ser.

He leído esto por internet:
http://www.klosions.com/prestashop-solucionar-problema-con-el-precio-con-iva-en-backoffice/

Ese es el problema que yo tengo, he realizado los cambios que dicen ahí pero de momento sigue igual. A ver si podéis echar un vistazo.

Gracias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 23/11/2017 5:58 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Veo que en la capturas de pantalla que estás enviado no se muestra el campo Precio de venta con IVA

Revisando el código fuente de la página que carga el formulario de edición de productos veo que esto ocurre cuando no se cumplen estas condiciones:

{if !$country_display_tax_label || $tax_exclude_taxe_option}

Esto indica que el problema lo tienes en la configuración de impuestos del país asociado con la tienda o que tengas directamente desactivados los impuestos.

Tendrías que revisar la configuración de los impuestos y la configuración de impuesto para el país que tienes asignado por defecto a la tienda.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/11/2017 1:00 pm

Cursos Gratuitos WordPress

Enrique
 Enrique
Famed Member

Buenos días Pablo,

Adjunto configuración de todo lo que me has comentado pero lo veo todo bien.

También hemos importado todo el paquete de datos de españa pero tampoco ha surgido efecto.

Gracias.

Espero tus noticias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 28/11/2017 9:41 am
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Realiza la prueba de quitar la configuración de impuestos y verifica si asi te aparece el precio.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/11/2017 4:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas tardes,

A ver, he realizado las siguientes pruebas.

1. En Localización=>Impuestos he desactivado y he vuelto a activar el impuesto llamado IVA ES 21. Cabe destacar que al desactivarlo ha desparecido el nombre y lo he tenido que volver a crear.

2. Más tarde, he ido a Localización => Reglas de Impuestos, y en el impuesto llamado "ES Standard rate (21%)" antes aparecía España, Bélgica, Francia, etc... pues cuando he entrado no tenía cargado ningún país, le he añadido españa y todas sus provincias con el Impuesto IVA ES 21. Adjunto captura de pantalla.

3. He ido a la configuración de un producto, he entrado en pestaña Precio y misteriosamente ahora si me calcula el precio con IVA y muestra la etiqueta en el backoffice que adjunto.

4. Sin embargo en Catalogo => Productos el precio sigue siendo cero y en la parte pública también.

5. Por útlimo he desactivado los impuestos como me has comentado y el único cambio que he notado, es que la web no muestra el texto "impuestos incluidos". Adjunto captura de los datos que he desactivado.

Gracias.

Espero noticias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 28/11/2017 5:37 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

Vamos a revisar algunas cosas.

.- Accede a cPanel -> phpMySQL
.- Selecciona la BD que utiliza tu instalación
.- Edita la tabla ps_product ( El prefijo ps_ puede ser distinto )
.- comprueba el campo cache_default_attribute este tiene que tener un valor de " 0 " , si es distinto lo cambias.

.- Realiza los mismos pasos para la tabla " ps_product_shop "

Recuerda realizar una copia de la BD antes de modificar nada.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 29/11/2017 9:25 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Famed Member

Buenas tardes,

¿Donde hay que poner el valor "0"?

Adjunto captura de pantalla.

Gracias.

Un saludo, Enrique P.

ResponderCitar
Respondido : 30/11/2017 5:32 pm
Página 1 / 3

Por favor Iniciar Sesión o Registro