Problemas con el multilenguaje en virtuemart  

 
Ramon
 Ramon
Usuario experto

Hola,

tengo un problema con el multilenguaje de mi tienda, pues al hacer una compra con el idioma en catalán hay texto que sale en inglés.

Configuré la tienda multilenguaje siguiendo las intstrucciones de vuestra entrada en el blog https://www.webempresa.com/blog/configurar-multiples-idiomas-en-virtuemart-20.html

He revisado, y tengo activado los dos idiomas en tienda multilingüe. También en categorías y productos lo tengo en los dos idiomas.

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 17/12/2013 10:44 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ramón,

¿Cabe la posibilidad de que al no tener el idioma Catalán para tu versión de VirtueMart "completamente" actualizado (las cadenas de idioma) a la versión de VirtueMart que usas, el componente lo que hace es sustituirlas por la cadena en inglés?.

Facilítanos una captura del Gestor de Idiomas de Joomla donde veamos cuales tienes instalados.

Entiendo que trabajas con Joomla 2.5.16 y VirtueMart 2.0.26 ¡correcto?.

Si observo en tu primera captura que tienes sin marcar la opción "Textos sin traducir en inglés" por lo que aduzco que hay un problema con cadenas que no existen en catalán y no son mostradas en crudo (la constante, no la traducción).

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/12/2013 10:57 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ramon
 Ramon
Usuario experto

Hola,

adjunto captura del gestor de idiomas. También se ve la versión del Joomla que es la 2.5.6. Del Virtuemart no estoy seguro que versión es, adjunto captura del acerca de...

Saludos.

ResponderCitar
Respondido : 17/12/2013 11:41 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ramón,

La versión 2.5.6 de Joomla fue una versión vulnerable, actualmente nos encontramos en la 2.5.16. El archivo de idioma que usas es de hace más de 1 año, la 2.5.8, bastante desfasado y seguramente le faltarán muchas cadenas nuevas.

Para actualizar de Joomla 2.5.6 a 2.5.16 estable, manualmente, debes realizar lo siguiente:

1. Copia de seguridad del sitio a actualizar, ya sea con Akeeba Backup, XCloner, o desde tu cPanel, Respaldos. (*1)
2. Verificar si existe nueva versión desde Componentes, Actualizar Joomla!.
3. Proceder a realizar dicha actualización.
4. Verificar en el backend, Sitio, Información Sistema, Versión Joomla! la nueva versión de Joomla.

*1:

- Copias de Seguridad desde el Panel de Hosting cPanel: https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html
- Copias de Seguridad en Joomla 2.5.x y 3.1.x con Akeeba Backup: https://www.webempresa.com/blog/realiza-copias-de-seguridad-y-restauraciones-en-joomla-3-con-akeeba-backup.html
- Copias de seguridad rápidas y sencillas en Joomla 2.5 con Easy Joomla Backup: https://www.webempresa.com/blog/copias-de-seguridad-en-joomla-25-rapidas-y-sencillas-con-easy-joomla-backup.html
- Copias de Seguridad con XCloner-Backup en Joomla 1.5, 2.5 y 3.0: https://www.webempresa.com/blog/copias-de-seguridad-con-xcloner-backup-en-joomla-15-25-y-30.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/12/2013 11:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ramon
 Ramon
Usuario experto

Hola,

Solucionado con la actualización del componente del idioma.

Gracias.

ResponderCitar
Respondido : 18/12/2013 7:07 am

Por favor Iniciar Sesión o Registro