Avisos
Vaciar todo

Configurar como Multisite, error  

 
Yolanda
 Yolanda
Usuario activo

Hola, estoy buscando convertir mi instalación de wordpress a multisite. Ya realicé los pasos para editar el wp-config y el .htaccess según el código dado por mi panel de administración. Pero al editar el wp-config me está dando problemas, porque al añadirle las siguientes líneas y recargar de nuevo la página me aparece un  "Esta página no funciona. La página lightmax.es no puede procesar esta solicitud ahora.
HTTP ERROR 500".

Si regreso a la configuración anterior, la página vuelve a funcionar. Estas son las líneas que añadí en wp-config (previamente desactivé todos los plugins):

define( 'WP_DEBUG', true );
define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WPLANG', 'es_ES' );
define( 'MULTISITE', true );  /* A PARTIR DE AQUÍ ES LO QUE ESTOY AÑADIENDO PARA MULTISITE */
define( 'SUBDOMAIN_INSTALL', false );
define( 'DOMAIN_CURRENT_SITE', 'lightmax.es' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

Contenido solo visible a usuarios registrados

Citar
Respondido : 01/07/2021 3:07 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Yolanda,

Antes que nada prueba solo añadiendo en tu archivo wp-config.php la linea define( 'MULTISITE', true ); luego validando de que tu WP aun funciona vas a buscar una nueva opción que ha sido añadida desde el apartado de herramientas-> configuración de la red

Desde esa opción vas a poder configurar como quieres distribuir tus sitios si desde subdominio o subdirectorios.

Nos comentas si has podido llegar a ese paso, de alli en adelante es la configuración convencional

Saludos

ResponderCitar
Respondido : 01/07/2021 3:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Yolanda
 Yolanda
Usuario activo

Hola Bruno,

En un principio ya había colocado en el wp-config la línea

define( 'WP_ALLOW_MULTISITE', true ); 
y posteriormente entré en mi admin panel a "Configuración de la red" y me indica que coloque las demás líneas de código, pero al
editar el wp-config, como lo mencioné arriba me da problemas.

Adjunto captura de pantalla.

imagen
 
ResponderCitar
Respondido : 01/07/2021 4:25 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Yolanda,

Perfecto, siguiendo las indicaciones tambien has modificado el archivo .htacess?

Saludos!

ResponderCitar
Respondido : 01/07/2021 4:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Yolanda
 Yolanda
Usuario activo

@bruno-vichetti

Así es, además del wp-config, también edité mi .htaccess y reemplacé todas las líneas de código por las líneas que me indica arriba, subo ambos archivos al servidor y al cargar la página me da el error 500, luego restauro mi wp-config al que tenía anteriormente y el sitio vuelve a funcionar, por eso deduzco que el problema está con este archivo.

ResponderCitar
Respondido : 01/07/2021 4:37 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Yolanda,

Si se ha seguido los pasos de manera correcta posiblemente exista un problema en como se esta configurando el sitio, te dejo el siguiente articulo que puede ayudarte a validar la configuración https://www.webempresa.com/blog/red-de-sitios-wordpress-en-varios-idiomas-sin-plugins.html

Hay que tener en cuenta que dependiendo de la finalidad que deseas orientar este cambio no recomendamos el uso de Multisitio por los problemas a futuro que conlleva mantenerlo.

Saludos!

ResponderCitar
Respondido : 01/07/2021 4:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación