Miércoles, 05 Diciembre 2018 23:05

WordPress 5.0 con Gutenberg ¿actualizar o esperar?

Escrito por  Luis Méndez Alejo
CMS:  WordPress |  Versión:  5.0 |  Nivel de dificultad:  Básico |  Tiempo estimado de lectura:  10 minutos
Valora este artículo
(5 votos)

WordPress 5.0 con Gutenberg


Hace ya bastante tiempo que Gutenberg irrumpió en WordPress para quedarse y ahora más que nunca con la llegada de la esperada versión "mayor" es necesario verse frente a frente con este editor y sopesar su uso o esperar a más adelante.

Llega WordPress 5.0 con Gutenberg y la pregunta es ¿actualizar o esperar?

 

¿Tengo que actualizar ahora?

WordPress no se actualizará automáticamente a la versión 5.0, tendrás que forzar tú la actualización desde el dashboard /wp-admin) y no recomendamos hacerlo.

No hay ningún motivo por el que tengas que actualizar ahora a WordPress 5.0, puedes seguir trabajando con la versión actual sin ningún problema.

Nuestra recomendación es NO actualizar a WordPress 5.0 mínimo hasta finales de Enero y seguramente te recomendaremos esperar más hasta que otros usuarios, desarrolladores o expertos en WordPress hayan pasado por el proceso de actualización y documenten todos los problemas conocidos, etc.

Previamente explicaremos en nuestro blog los pasos recomendados y como verificar los plugins habituales que aun no sean compatibles, etc.

  • Si estás en plena temporada alta NO actualices.
  • Si no eres experto en WordPress NO actualices.
  • Si no quieres pasarte unas horas de incertidumbre para acabar recuperando un backup NO actualices.
 
Si eres cliente de Webempresa, te mantendremos informad@ a partir de finales de Enero 2019 con mensajes en tu Área de Cliente, cPanel y a través de este Blog con información puntual para que sepas como actualizarte con seguridad y tranquilidad a WordPress 5.x.

Con un 60% de cuota del mercado mundial de CMS, es importante que WordPress garantice la estabilidad por encima de nuevas funcionalidades.

Si actualizaste es importante que tengas copia de seguridad anterior, lo cierto es que esto siempre lo es, aunque si eres cliente de Webempresa con SuperBackup puedes estar un poco más relajad@ ¡tenemos backups para aburrir!, no obstante sigue leyendo antes de darle al botón de actualizar....

   

 ¿Qué opinamos sobre Gutenberg o WordPress 5.0?


Creemos que WordPress 5.0 es un gran paso adelante, sin embargo nuestro perfil de cliente no es experto en WordPress, simplemente queremos ser prudentes y evitar problemas a nuestros clientes no expertos, por ese motivo recomendamos posponer la actualización hasta que se solucionen las incompatibilidades que están surgiendo.

Tanto Gutenberg como las mejoras que hay previstas en el roadmap de WordPress nos parecen muy acertadas pero nosotros hubiésemos visto mejor un desarrollo con pasos intermedios para llegar a la implementación de Gutenberg.

Por ejemplo, una actualización 5.0 que mantuviese el editor clásico instalando automáticamente el plugin de classic-editor para que los usuarios pudiesen ir probando Gutenberg o el editor clásico poco a poco, sin verse forzados al cambio, y en nuevas instalaciones que ya tuviesen Gutenberg por defecto.

Vemos que Gutenberg aún tiene fallos y no parece lo suficientemente pulido como para ser el editor por defecto. Lo más probable es que en los próximos 3 meses estén resueltos todos estos pequeños problemas que tiene Gutenberg, pero ahora pueden dificultar el día a día del usuario no experto y que lo que necesita es publicar contenido y no ser un experto en WordPress.

Básicamente se trata de que tenemos un punto de vista diferente al del equipo de WordPress ya que ellos tienen en cuenta todo tipo de usuarios de WP y nosotros el perfil de nuestro cliente, confiamos en el buen trabajo de Automattic y en el futuro de WordPress, pero por nuestro perfil de cliente hace que seamos más conservadores sobre cómo habría que recorrer el camino para llegar al mismo punto.

A los usuarios expertos, programadores, early adopters, etc., les animamos a actualizar a WP 5.0 y que nos reporten problemas y soluciones que hayan encontrado. En las próximas semanas iremos publicando contenidos para la comunidad y para nuestros clientes, en los que expliquemos cómo ir solventando los problemas que hayamos visto al actualizar y en el uso de WP 5.0. Seguimos habitualmente todo lo relacionado con el mundo-press para poder dar un buen soporte y estar adaptados constantemente a los cambios.

 

 ¿Qué novedades incorpora WordPress 5.0?


Según Matt Mullenweg, en su artículo de 04/12 deja claro que el 6/12/18 se libera WordPress 5.0 donde de facto si vendrá Gutenberg activo como editor para Entradas y Páginas.

Esto no es en sí una novedad porque hace más de 1 año que sabemos (al menos los que dedicamos muchas horas a este CMS) que la incorporación "oficial" de Gutenberg vendría de la mano de la versión mayor 5.0 por lo que no es sorpresa.

Lo que si sorprende es que este tipo de actualizaciones por costumbre o el azar vengan cayendo más bien cuando la gran mayoría de usuari@s están de vacaciones, o descansando unos días, y suele pillar de sorpresa al regreso, a veces con un desagradable "error 500" o la web medio desmontada.

No obstante con WordPress 5.0 se esperan mejoras, como siempre, algunas conocidas como:

  • Incorporación de Gutenberg 4.6 como editor nativo.
  • Nuevo tema Twenty Nineteen compatible con Gutenberg y sus bloques.
  • Añadidas 5 etiquetas nuevas para Custom Post Types.
  • Mejoras en la WordPress Rest API.
  • PHP 7.3 soportado "y versión recomendada".
  • Repaso a la seguridad y la usabilidad.
  • Otras mejoras menores que informaremos llegado el momento.
 

 Algunos plugins pueden verse afectados por esta actualización


En la mayoría de instalaciones esta actualización se aplica de forma automática a menos que se tenga deshabilitado la actualización de versiones mayores por defines o desde WPCenter (para clientes de Webempresa), lo que implica que las webs se actualizarán para bien (mejoras, seguridad, etc) o para dar algún que otro quebradero de cabeza si se utilizan plugins como:

  • WPML (Multiidiomas).
  • Advanced Custom Fields (ACF).
  • ..otros aún no determinados.

Es posible que algunos plugins de constructores (Page Builder, etc) se puedan ver afectados también por esta actualización (sin confirmar).

En líneas generales significa que la compatibilidad con estos plugins y Gutenberg no está al 100%, que no se garantiza por parte de los desarrolladores de estos plugins lo que puede traducirse en problemas, perdida de funcionalidades o que el sitio se rompa presentando errores 500 en el peor de los casos, algo que no necesariamente tiene porqué suceder.

Pero si algo de esto sucede toca volver a la versión 4.9.8 y quedarse en ella al menos hasta mediados/finales de enero de 2019 donde supuestamente las cosas se irán normalizando.

Los autores del plugin Advanced Custom Fields (ACF) comentan en su web el problema.

También los desarrolladores del plugin WPML explican que es mejor no actualizar de momento a WordPress 5.0 para evitar problemas con el plugin y el CMS.

Si te ves afectado por problemas tras la actualización, indicarte que la solución más inmediata es restaurar un backup anterior (si tienes tu propia política de copias de seguridad) o utilizar “SuperBackup” (si eres cliente de Webempresa), y luego mantenerte en WordPress 4.9.8 hasta que mejore el tiempo y haya una compatibilidad más garantizada.

Si te has preguntado si tu Tema en uso (además de los plugins) tendrá problemas con Gutenberg, la respuesta es "no los tendrá" ya que los temas actuales, compatibles con WordPress 4.9.x y por ende con 5.0 son compatibles con bloques y por tanto con Gutenberg.

 

 ¿Gutenberg o Editor Clásico?


Desde algunas instancias y desde la comunidad de WordPress se han alzado voces críticas con la incorporación definitiva de Gutenberg en WordPress 5.0 considerándose que "no es estable para sitios en producción".


Gutenberg no estable en versiones RC

Haz clic en la imagen para ampliarla  

Con pocos días de margen para probar versiones RC (released candidate) se cuestiona que estas sean "estables" y que deban dar pie a la versión oficial de WordPress 5.0 casi de inmediato.

WordPress no parece cumplir los estándares de usabilidad, lo que obliga a usuarios con discapacidades a descargar plugins de terceros para poder hacer uso de esta versión.

A fecha de hoy siguen abiertos 285 issues al respecto.


Issues Gutenberg abiertos

Haz clic en la imagen para ampliarla  

No obstante la intención de este artículo no es remarcar los problemas que afectan a Gutenberg y su incorporación en WordPress 5.0, sino informar de la importancia de tomar las debidas precauciones antes de actualizar, o usar el sentido común y esperar un tiempo a que las aguas vuelvan a su cauce para actualizar.

Es por ello que si por la razón que sea decides actualizar, sepas que puedes desactivar Gutenberg y activar el Editor Clásico para poder seguir editando Entradas o Páginas sin perder las actuales funcionalidades de tu web.

El plugin "Classic Editor" tendrá soporte oficial hasta 2022.

Si no tienes el "Editor Clásico" instalado, por la razón que sea, puedes descargarlo, instalarlo y activarlo para hacer uso del mismo en tu web.

Classic Editor

Haz clic en la imagen para ir al enlace del plugin  

 

 Opiniones de usuarios ¡eco de la comunidad!


Si no lo tienes claro aún, después de estas pinceladas, es bueno que te des una vuelta por las redes sociales y leas lo que algunos expertos y grandes contribuidores a WordPress.org y su comunidad en España opinan del tema.

     

Si quieres saber más hazte un search en tu cuenta de Twitter con hashtag #gutenberg o #wordpress50 y ponte al día para que no te pille de sorpresa.

 

 Conclusiones


En el 99% de los casos en los que se liberan nuevas versiones de WordPress siempre recomendamos, desde Webempresa, actualizar previa realización de una copia de seguridad.

En esta ocasión, y atendiendo a la cautela, te recomendamos "esperar", no actualizar de inmediato, y si tenías activadas las "actualizaciones mayores" mediante defines en wp-config.php o de otras formas, que las desactives y tomes el control de cómo y cuando aplicarlas.

Deseando mucho que en la #WCUS en Nashville se pongan las pilas y abran las puertas a la siguiente versión de WordPress 5.0.1 donde se resuelvan estas incompatibilidades que permitan a los millones de usuarios, implementadores y desarrolladores en torno a este CMS hacer lo que mejor saben hacer ¡disfrutar con WordPress!

 

Hay muchas y buenas razones para esperar a finales de enero de 2019 para actualizar a WordPress 5.x (lo que toque) y espero que te lo podamos contar aquí y que sean buenas noticias para un ¡Feliz WordPress 2019!Amamos lo que hacemosWordPress

Mientras, si por alguna razón has actualizado o te has tropezado con el problema tras volver de las mini-vacaciones, recuerda que en Webempresa hacemos mogollón de copias de seguridad que tienes disponibles en tu cPanel, con Superbackup.

     

¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress



Luis Méndez Alejo

Luis Méndez Alejo

Miembro del equipo técnico de Webempresa.
Coordinador de contenidos en el Blog y en Youtube.
Google+


Plugin Optimización de Imágenes Gratuito para WordPress