Viernes, 22 Febrero 2019 20:32

WordPress 5.1 con soporte de salud y versiones PHP

Escrito por  Luis Méndez Alejo
CMS:  WordPress |  Versión:  5.1.x |  Dificultad:  Básico |  Tiempo lectura:  5 minutos
Valora este artículo
(1 Voto)

WordPress 5.1


Llega WordPress 5.1 como la primera versión "mayor" de 2019 incorporando avisos de actualización de PHP, mejoras en el editor de bloques y primeras incorporaciones para gestionar la salud del sitio desde el dashboard.

Sigue habiendo muchos usuarios estancados en WordPress 4.9.9 esperando al momento ideal para llevar a cabo este update de WordPress de forma estable y segura para sitios que aún pueden presentar incompatibilidades de algunos plugins con el "editor de bloques" Gutenberg, para los que la recomendación "si no lo tienen 100% claro" es esperar a la 5.2 en abril de este año.

Para el resto de usuarios que ya están en la versión 5.0.3 podrán ejecutar esta actualización, previa copia de seguridad, sin miedo a que su sitio quede inoperativo.

   

¡Siempre! antes de actualizar es importante que realices una copia de seguridad (si tu actualización no es automática).

 

 Vulnerabilidades y correcciones


  • Se han aplicado 51 correcciones al editor de Bloques, añadiendo 3 bloques procedentes de widgets y 21 mejoras para el funcionamiento global del plugin.
  • Se añade control de compatibilidad de versiones de PHP para plugins y el core.
  • WordPress comenzará a mostrar avisos a los administradores de sitios que ejecutan versiones anticuadas de PHP.
  • Se ven las primeras características "tímidas" de la gestión de salud del sitio web, denominadas Site Health que se centrarán en mostrar avisos y evitar que se realicen instalaciones de plugins que no soporten la versión de WordPress o de PHP activadas.
  • Se añade una nueva tabla a la base de datos para almacenar "metadatos" asociados a sitios y permitir el almacenamiento arbitrario de datos relevantes de un sitio dentro del contexto de "red de sitios" (multisitios).
  • La API de Cron se actualiza con nuevas funciones para ayudar a devolver datos, también incluye nuevos filtros para modificar el almacenamiento cronológico.
  • Se aplican cambios en el comportamiento del Cron de API que afectan a la generación de cronjobs en servidores que ejecutan FastCGI y PHP-FPM en versiones 7.0.16 y superiores.
  • Se mejora la limpieza de la caja metaboxes de taxonomías.
  • Cambios menores en avisos en la REST API.
 

 Mejoras en el Editor de Bloques


A partir del presente artículo, en estos que dedicamos a las actualizaciones de WordPress, abrimos un apartado específico para comentar las mejoras que va recibiendo el "Editor de Bloques" Gutenberg, para que estés informado y puedas sacarle el rendimiento deseado.

En WordPress 5.1 también Gutenberg se actualiza a la versión 5.1 e incorpora mejoras como que los widgets nativos de WordPress pasan a ser bloques para quedar integrados en el nuevo editor.

Se añaden:

  • Bloque de Búsquedas.
  • Bloque de Calendario.
  • Bloque de Nube de Etiquetas.

En esta nueva versión se han refactorizado los botones de de formato y el componente RichText para mejorar el flujo de la escritura.

Los bloques centrales ya no hacen uso de TinyMCE y se han mejorado el resto de bloques existentes y las micro-animaciones UI.

Desde la versión 4.7 de Gutenberg, que tenía tiempos de carga de 15,1 segundos, estos se han mejorado notablemente en la versión 5.1 bajando hasta los 9,4 segundos para la carga de Entradas de 3600 palabras y 1000 bloques aproximadamente.

Recuerda que si lo tuyo no es todavía vértelas con el "editor de bloques" siempre puedes optar por instalar el "Editor Clásico" y seguir usándolo en la edición de tus Entradas y Páginas como has hecho hasta antes de la salida de WordPress 5.0 en diciembre de 2018.

Si no tienes el "Editor Clásico" instalado puedes descargarlo, instalarlo y activarlo para hacer uso del mismo en tu web.

Classic Editor

Haz clic en la imagen para ir al enlace del plugin  

El plugin "Classic Editor" tendrá soporte oficial hasta 2022.
 

 Avisos de Actualizaciones


Si al acceder al dashboard de WordPress ves el siguiente mensaje en Escritorio, Actualizaciones:


Disponible actualización a WordPress 5.1

Haz clic en la imagen para ampliarla  

Pero no quieres pasar de WordPress 4.9.9 a la nueva versión 5.1, entonces lo mejor es que ignores dicho mensaje, al menos hasta el 23 de abril de 2019 cuando se libere WordPress 5.2 y se pueda zanjar de una vez el problema de incompatibilidad de algunos plugins con Gutenberg.

Si en el dashboard, en el "Escritorio", Actualizaciones compruebas que tienes plugins y temas pendientes de actualizar, realiza primero la actualización de estos ítems antes de realizar la actualización del núcleo de WordPress a la versión 5.1.

Si después de aplicar la actualización de tu sitio web, no ves la página, limpia la caché de tu navegador y verifica si sigue activo el "modo mantenimiento" que suele ser la causa habitual de que no veas la web al haber hecho clic en otro elemento del dashboard de tu web mientras se actualizaba WordPress.

 
Si continúas en WordPress 4.9.9 y no quieres actualizar "de momento", no te preocupes, las actualizaciones a WordPress 5.x no se aplican de forma automática y en Webempresa aplicamos reglas de seguridad para evitar que tu sitio sea vulnerable durante este impasse.
 

Consulta la Lista de cambios en WordPress 5.1 para más detalles en el Make WordPress Core.

 

 Actualizar a WordPress 5.1


La actualización a la versión 5.1 no es automática ya que se trata de una versión "mayor" por lo que es necesaria tu intervención para proceder a realizarla, de otra forma tu sitio no aplicará dicha actualización a menos que la hayas forzado desde wp-config.php con defines o mediante algún plugin específico.

Es MUY IMPORTANTE destacar que por defecto si tu WordPress ejecuta la versión 4.9.9, y utilizas el actualizador de "Escritorio", "Actualizaciones", pasarás directamente a la versión 5.1, teniendo que utilizar el "editor de bloques" salvo que ya tengas el "editor clásico" previamente instalado y activo.

Si eres cliente de Webempresa y tienes activado en tu cPanel, Aplicaciones Webempresa, WPCenter las actualizaciones menores y mayores de forma automática, en "Opciones", pestaña Auto Update, indicarte que no se aplicará esta actualización ya que se encuentra deshabilitada para evitar actualizaciones desde WordPress 4.9.9 a 5.1 de forma involuntaria o no deseada.

Si tras la actualización compruebas que se presentan problemas, incompatibilidades con plugins activos o tu Tema en uso, puedes recurrir a una copia de seguridad para volver a una fecha anterior donde tu web funcione con normalidad.

Lectura recomendada: https://www.webempresa.com/blog/copias-seguridad-superbackup-cpanel-dominalas.html
 

 Conclusiones


WordPress 5.1 es una versión mayor, que como todas las de esta serie, trata de incorporar mejoras y características destacadas con respecto a la anterior versión. En este caso ha sido Site Health de forma algo tímida pero prometiendo más implementaciones para la siguiente versión 5.2 en abril de este año.

 

Como viene siendo ya habitual, desde diciembre de 2018, la recomendación es no actualizar a WordPress 5.1 si sigues estancad@ en la versión 4.9.9 al menos hasta después del 23 de abril, y así dar tiempo a que determinados plugins aseguren la compatibilidad con el "editor de bloques" Gutenberg.

     

¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress



Luis Méndez Alejo

Luis Méndez Alejo

Miembro del equipo técnico de Webempresa.
Coordinador de contenidos en el Blog y en Youtube.
Soporte técnico en CiberProtector.


Plugin Optimización de Imágenes Gratuito para WordPress