blog webempresa

Cómo Solucionar, “Parece que Tu Instalación de PHP no Cuenta con la Extensión de MySQL, Necesaria para Hacer Funcionar WordPress”

por | Feb 22, 2023 | Errores en WordPress

Cómo Solucionar, “Parece que Tu Instalación de PHP no Cuenta con la Extensión de MySQL, Necesaria para Hacer Funcionar WordPress

Cuando decidimos instalar WordPress ya sean dentro de nuestra cuenta de hosting o en un entorno local podemos encontrarnos con algunos errores que puedes saltar las alerta y frustrarnos, algunos de estos errores comunes que suelen mostrarse es el famoso “Parece que tu Instalación de PHP no Cuenta con la Extensión de MySQL, Necesaria para Hacer Funcionar WordPress”.

Este tipo de errores en WordPress suelen mostrarse cuando la instalación que realizamos no es compatible con la versión PHP que tenemos actualmente configurado dentro de nuestro servidor, en esta entrada veremos como podemos solucionar este error y así poder realizar de forma exitosa la instalación de tu CMS WordPress.

 ¿Qué es MySQL?

Esto no es más que un sistema de gestión de base de datos relacionales (RDBMS), fue desarrollado bajo licencia de código abierto y es respaldado por Oracle. Está basado en un lenguaje de consulta estructurado (SQL) y que funciona prácticamente en todas los sistemas operativos como Linux y Windows

En pocas palabras podemos decir que es software utilizado para crear y administrar bases de datos, este software está detrás de muchos de los principales sitios web que actualmente se encuentran en internet así como en diferentes aplicaciones de consumos basados en la web.

MySQL está basado en un modelo cliente/servidor siendo el núcleo MySQL encargado de manejar todas las instrucciones o diferentes comandos de nuestra base de datos. El servidor es donde se almacena la información mientras que el cliente es quien envía la solicitud de información que necesita a través de una sentencia SQL.

 ¿Qué causa el error de la extensión MySQL en WordPress?

Este mensaje de error que en ocasiones puede presentarse puede aparecer por diferentes factores, de los cuales podremos decir los más importantes como:

1.— Estás usando una versión de PHP que nos es compatible con la versión del software que intentan instalar, en este caso por ejemplo, WordPress. Dado que la extensión MySQL esta en desuso y ya no se admite en versiones de PHP 7.0 y posteriores.

Este error suelen presentarse dentro de WordPress cuando utilizamos una versión antigua del núcleo de WordPress, pero tenemos una versión reciente de PHP, algo que tenemos que tener en cuenta que debido a la constante actualización de núcleo principal de WordPress su código se actualiza y por ende también los requisitos, extensión o versión de PHP WordPress que necesitamos para correr de forma correcta el CMS en nuestro servidor.

Versiones anteriores a la 3.9 si admiten aún esta extensión, sin embargo, versiones posteriores pueden generarnos este tipo de error.

2.— Estás usando una versión PHP 5.6, pero la extensión no está correctamente configurada.

Si estás utilizado la versión correcta y tu WordPress es compatible con versiones PHP 5.6 o inferiores, pero aún recibes este error es posible que esto se deba a que la extensión está mal configurada dentro de tu cuenta de hosting y por ello recibas este mensaje.

 Cómo podemos solucionar el error “Parece que tu instalación de PHP no cuenta con la extensión de MySQL, necesaria para hacer funcionar WordPress”

Una vez conocemos porque pueden presentarse estos errores en una página web WordPress podremos indagar y revisar de forma más detallada que puede estar ocasionando este error molesto en nuestro sitio web.

Lo primero que necesitamos verificar es que versión de PHP estamos utilizando en nuestra cuenta de hosting, para poder revisarlo lo primero que necesitamos hacer es ingresar dentro denuesta cuenta de cliente y acceder a nuestro cPanel / wePanel.

Una vez nos encontramos en nuestra cuenta puedes dirigirte a wePanel / cPanel -> Otras Herramientas -> Versiones PHP y comprobar la versión PHP que tienes activa para tus sitios web, verás el listado completa de cada uno de tus dominios con la versión PHP configurada para este sitio web.

Versión de PHP instalado

Esta información nos permite determinar si será necesario cambiar versión de PHP del Hosting.

Otra opción que podremos revisar para saber qué versión actualmente tenemos en nuestro sitio web es crear un archivo llamado phpinfo.php dentro del directorio donde tenemos los archivos de nuestro sitio web en WordPress.

Una vez tienes el archivo creado solo necesitas pegar las siguientes líneas de código y guardar los cambios.


<?php

phpinfo();

?>

Crear archivo phpinfo WordPress

Una vez añadida las líneas de código guarda tu archivo y ejecútalo accediendo a la URL de tu dominio, por ejemplo https://tudomonio.com/phpinfo.php dentro de los resultados que se muestran verás información sobre la configuración de PHP que tienes.

 Ten en cuenta modificar https://tudomonio.com por el dominio de tu instalación

Para ubicar cuál es tu versión solo debes ir a la sección core y verificar que versión tienes activa, si la versión que actualmente utilizas inicia con un 7 esto quiere decir que para poder solucionar este error necesitarás actualizar la versión principal de WordPress.

Ten en cuenta que lo más recomendable es utilizar versiones recientes tanto de PHP como el core de WordPress principal, ya que esto permite tener mayor seguridad dentro de nuestro sitio web y evitar posible problema a futuro con intento de hackeo en tu sitio web.

 Actualiza la versión de WordPress que estés utilizando.

Como mencionamos uno de los principales problemas por los que suele mostrarse este error es porque utilizado una versión de PHP 7+ y en nuestro sitio web estamos utilizando una versión de WordPress muy antigua, si estás usando una versión 3.9 o inferior de WordPress es muy importante que lo actualices.

Al actualizar nuestra versión de WordPress estamos garantizando compatibilidad no solo con nuestra versión PHP sino también con las nuevas versiones de plugins y tema que usemos en ese momento, además de garantizar que tendremos nuevas características, funcionalidades para nuestro sitio web asi como optimizar base de datos de WordPress.

 Antes de actualizar WordPress de forma automática es importante revises la compatibilidad de tu tema y plugins con las nuevas versiones del núcleo de WordPress así como asegurarte de crear una copia de seguridad en WordPres de tu sitio web para recuperar información de ser necesaria y si se genera algun error durando el proceso de actualización.

Una vez has comprobado esta información para actualizar tu sitio web necesitas descargar una copia de la versión reciente del WordPress desde su sitio web oficial wordpress.org.

Descargar version reciente de WordPress

Una vez hayas descargado de forma correcta el archivo wordpress.zip en tu ordenador lo siguiente será extraer el contenido actual de este archivo, al extraerlo verás una carpeta que contiene todos los archivos de WordPress, de esta carpeta debes eliminar los siguientes:

  • El archivo wp-config-sample.php.
  • El archivo wp-config.php (es posible que no veas este archivo, pero es importante asegurarte de borrarlo si está dentro del directorio).
  • La carpeta wp-content.

Una vez eliminados puedes conectarte a tu cuenta de hosting a través de FTP y subir los archivos necesarios para la actualización, al comenzar a subirlos se mostrará un mensaje que te indica que están duplicados, solo debes marcar la opción de reemplazarlos y aceptar la transferencia.

Actualizar WordPress FTP

Al finalizar la transferencia de los archivos en la carpeta de tu sitio web puedes probar cargar nuevamente tu sitio web, al tener una versión más reciente de WordPress este error debe desaparecer y estar solucionado.

El siguiente que necesitas realizar será:

  • Actualiza el tema actual de tu sitio web
  • Actualizar los plugins de WordPress

 ¿Utiliza una versión PHP 5.6 o inferior, pero aún te muestra el error?

En estos casos sí, por el contrario, usas la versión 5.6 y tienes una versión de WordPress 3.9 o inferior, esto quiere decir que hay un problema con la configuración de la extensión de tu PHP; en este caso lo mejor será contactar con soporte técnico de tu cuenta de hosting para que revisen lo que sucede y te ayuden a configurarla de forma correcta.

Ten en cuenta lo que hemos mencionado a lo largo de este artículo, la seguridad de tu sitio es primordial y por ello lo que recomendamos es que actualices a una versión de WordPress reciente al igual que una versión de PHP actual que te permita tener la seguridad que necesitas y evitar así mayores problemas a futuro, por si se diera la situación de que debas restaurar WordPress.

Siempre tenemos que tener en cuenta que un sitio web construido con WordPress u otra tecnología necesita estar actualizado, esto permitirá mejorar el rendimiento de tu sitio web y a su vez la seguridad con respecto a una versión anterior.

Puedes revisar un poco más todos los detalles sobre porque es importante actualizar WordPress y así mantenerte al día con las últimas características liberadas por los desarrolladores y equipo de soporte de WordPress.

 Conclusiones:

Este mensaje que se nos muestra “Parece que tu instalación de PHP no cuenta con la extensión de MySQL, necesaria para hacer funcionar WordPress” es un error que puede parecernos un poco difícil, ya que nos puede parecer necesitemos un conocimiento técnico avanzado sobre MySQL.

Sin embargo, como pudimos ver este tipo de error suelen presentarse solo por la versión de PHP utilizada o por utilizar versiones antiguas de WordPress y PHP, ahora puede resultar un poco más sencillo diagnosticar porque se puede estar presentando este error en mi sitio web y de que forma puede solucionarlo para no estar con mi sitio web inactivo por mucho tiempo.

También te puede interesar:

¿Te ha resultado útil este artículo?

Promo hosting 70% de descuento